Написать программу (в паскаль) по закупке товаров в магазине на определённую сумму денег, не превышающую заданное количество денег. входные данные: с клавиатуры вводится сумма, на которую предполагается произвести покупки. затем вводятся цена и количество товара №1, товара №2 и т.д. до тех пор пока не будет исчерпана сумма денег.

ВаняШколяр4536 ВаняШколяр4536    2   04.06.2019 14:40    1

Ответы
AndrewDremin AndrewDremin  05.07.2020 14:03
Uses crt;
var s:integer;
     b,y,a:real;
begin
write('Введите сумму денег, на которую собираетесь произвести покупки: ');
read(a);
while a>0 do begin
  s:=s+1;
  write('Товар №',s,': ');
  read(b);
  write('Введите количество: ');
  read(y);
  a:=a-(b*y);
 end;
end.
ПОКАЗАТЬ ОТВЕТЫ
putWrite1 putWrite1  05.07.2020 14:03
Uses crt;
var
sum,x,itog: real;
i,y: integer;
begin
i:=1;
itog:=0;
write ('Start summa: ');
readln (sum);
while (itog<sum) do
begin
write ('¹',i,': ');
i:=i+1;
readln (x);
write ('Kol-vo: ');
readln (y);
itog:=itog+y*x;
end;
if (itog>sum) then
writeln ('Itog: ',itog-y*x)
else
writeln ('Itog: ',itog);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика