Написать программу (в паскаль) , которая вводит число и выводит ее половину, четверть, одну восьмую, одну шестнадцатую.​

Demirline Demirline    2   09.04.2019 11:59    6

Ответы
brukaya brukaya  28.05.2020 23:56

1 Вариант без использования цикла

program delenie1;

var a:real;

begin

write('Введите число: ');

readln(a);

writeln('Половина: ', a/2);

writeln('Четверть: ', a/4);

writeln('Одна восьмая: ', a/8);

writeln('Одна шестнадцатая: ', a/16);

end.

2 Вариант с использованием цикла

program delenie2;

var a:real;

i:integer;

begin;

write('Введите число: ');

readln(a);

for i:=1 to 4 do

 begin

 a:= a/2;

 writeln(a);

 end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика