1)дано трехзначное число.составьте программу которая определяет а)является ли сумма его цифр нечетным числом 2)составьте программу в которой осуществляется вот целых чисел до тех пор пока не будет введен 0 и подсчет а)количество чисел оканчивающихся на 6 и кратных 4 б)сумма чисел оканчивающихся на 6 и кратных 4 на языке паскаль

alobatsevi4 alobatsevi4    3   01.09.2019 23:00    7

Ответы
zhanik2017 zhanik2017  06.10.2020 10:47
1)
Program hhh54;
var x:longint;
begin
  read (x);
  if ((x div 100) + ((x div 10) mod 10) + (x mod 10)) mod 2 <> 0 then write ('ЯВЛЯЕТСЯ')
  else write ('НЕ ЯВЛЯЕТСЯ');
end.

2)
а)
Progran hhh54;
var i,k,x:longint;
begin
  k:=0;
  read (x);
  while x <> 0 do
    begin
      if (x mod 10 = 6) and (x mod 4 = 0); then k:=k+1;
      read (x);
    end;
  write (k);
end.

б)
Progran hhh54;
var i,s,x:longint;
begin
  s:=0;
  read (x);
  while x <> 0 do
    begin
      if (x mod 10 = 6) and (x mod 4 = 0); then s:=s+x;
      read (x);
    end;
  write (s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика