Написать программу в паскаль 1) дано n число, верно ли, что сумма его цифр четное число 2) найдите сумму его цифр больше 5 !

maxb5778 maxb5778    1   25.09.2019 18:01    4

Ответы
132132456789 132132456789  08.10.2020 19:00
Первая
var n,a:integer;
begin
a:=0;
WriteLn(n);
while n>0 do
begin
a:=a + (n mod 10);
n:=n div 10;
end;
end.

Вторая
var n,a:integer;
begin
a:=0;
WriteLn(n);
while n>0 do
begin
if n mod 10>5 then
begin
a:=a + (n mod 10);
end;
n:=n div 10;
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика