Написать программу в pascal. старинная . сколько можно купить быков, коров и телят, если плата за быка 5 рублей, за корову - 3 рубля, за теленка - полтинник (0,5 рубля), если на 100 рублей надо купить 100 голов скота. плюс 1 , если алгоритм эффективный.
program raf105;
const
s = 100;
var b,k,t: integer;
begin
writeln('Все возможные решения задачи:');
for b:=0 to (s div 5)+1 do
for k:=0 to ((s - b*5) div 3)+1 do
begin
t := trunc( (s - b*5 - k*3) / 0.5 );
if ((b+k+t) = 100) and ( (b*5+k*3+t*0.5)=s)
then begin
writeln;
writeln('Быков: ',b);
writeln('Коров: ',k);
writeln('Телят: ',t);
end;
end;
end.
PascalABC 3.4.2