Написать программу в pascal, которая выводит массив с образованного из массивов а и в формулой: c[i,j]=a[i,j]/b[i,j]. размеры массивов 3х3. ввод массивов а и в осуществлять в строчку, через пробел. массив с должен представлять из себя матрицу.

помоги270 помоги270    1   09.09.2019 17:30    13

Ответы
daniktsarev daniktsarev  07.10.2020 03:38
// PascalABC.NET 3.3, сборка 1561 от 02.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('Введите в строку элементы массива A[3x3]');
  var A:=ReadMatrReal(3,3);
  Writeln('Введите в строку элементы массива B[3x3]');
  var B:=ReadMatrReal(3,3);
  var C:=new real[3,3];
  for var i:=0 to C.RowCount-1 do
    for var j:=0 to C.ColCount-1 do
      C[i,j]:=A[i,j]/B[i,j];
  Writeln('*** Массив С ***');
  C.Println(10,5)
end.

Пример
Введите в строку элементы массива A[3x3]
3 5 -2 1.5 0.7 6 -0.5 4 2.2
Введите в строку элементы массива B[3x3]
0.6 5 3 7.4 -7.13 9.1 -2 0.8 6.42
*** Массив С ***
   5.00000   1.00000  -0.66667
   0.20270  -0.09818   0.65934
   0.25000   5.00000   0.34268
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика