Program primer_1; var v,a,b,c,r,h: real; var num: integer; begin writeln('введите значение num'); writeln('num='); readln(num); case num of 1: writeln('введите значения a,b,c'); write('a='); readln(a); write('b='); readln(b); write('c='); readln(c); v: =a*b*c; writeln('v=',v: 8: 3); 2: write('bвежите значения r'); write('r='); readln(r); v: =4/3*pi*power(r; 3); writeln('v=',v: 8: 3); 3: write('введите значения r,h'); write('r='); readln(r); write('h='); readln(h); v: =1/3*pi*sqr(r)*h; wrireln('v=',v: 8: 3); else write(‘введено число вне диапазона 1-3! ’); end. пытаюсь написать программу в которой от того какую цифру из трех ты выберешь будет зависеть объем какой из трех фигур надо будет найти. вижу что ошибка в использовании оператора case, как будто нельзя писать какие-то другие действия кроме write после 1: 2: 3:

nastyabulgakov1 nastyabulgakov1    1   12.06.2019 18:30    2

Ответы
ната555555 ната555555  10.07.2020 06:54
Кажется понял в чем проблема.У вас не работало т,к, отсутствовали begin и end; в case .Плюс еще пару недочетов в коде
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика