Написать программу, в которой массив из 20 элементов заполняется случайными числами и вычисляется произведение всех элементов массива.

Дмитрий1425 Дмитрий1425    3   16.07.2019 01:50    574

Ответы
dgolovenko dgolovenko  13.08.2020 17:28
// PascalABC.NET 3.0, сборка 1144 от 16.01.2016
begin
  var a:=ArrRandom(20,-15,25); a.Println;
  var p:BigInteger:=1;
  foreach var x in a do p*=x;
  Writeln('Произведение элементов равно ',p)
end.

Тестовое решение:
-3 5 8 -14 10 19 18 -15 15 -13 22 9 7 20 -12 6 6 -8 -3 -8
Произведение элементов равно 38640208365158400000
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика