Напишите в питоне , Алгоритм вычисления значения функции
F(n), где n – натуральное число,
задан следующими соотношениями:
F(n) = 1 при n = 1;
F(n) = n +F(n − 1), если n чётно,
F(n) = 2 * F(n − 2), если n > 1 и при этом n нечётно.
Чему равно значение функции
F(26)?

Kakation Kakation    2   19.01.2022 16:32    1

Ответы
krasilnikovaa98 krasilnikovaa98  19.01.2022 16:40

4122

Объяснение:

def F(n):

   if n == 1:

       return 1

   elif n % 2 == 0:

       return n + F(n - 1)

   else:

       return 2 * F(n - 2)

print(F(26))

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика