Написать программу в free pascal'e,! условие: пусть k - целое от 1 до 365. присвоить целой переменной n значение 1, 2, 6 или 7 в зависимости от того, на какой день недели (понедельник, вторник, субботу или воскресенье) приходится k-й день не високосного года, в котором 1 января - понедельник.

lunenko2005 lunenko2005    1   26.08.2019 02:50    4

Ответы
Надежда777333 Надежда777333  05.10.2020 20:07
Var k,n:integer;
begin
write('k = ');
readln(k);
n:=(k-1) mod 7+1;
writeln('n = ',n);
end.

Пример:
k = 21
n = 7
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика