Написать программу. угадай число. один из партнеров вводит в программу число, а второй должен отгадать это число. причем на каждый предложенный вариант программа отвечает либо «больше», либо «меньше» до тех пор, пока число не будет отгадано. вывести количество попыток, которое было сделано.

ketjaan13 ketjaan13    1   19.06.2019 16:40    2

Ответы
AlexKostrov AlexKostrov  15.07.2020 20:58
Var a,i,b:integer;
begin
  writeln('Введи число');
  readln(a);
  writeln('Уадай');
  while a<>b do
  begin
  readln(b);
  if a<b then 
  begin writeln('Меньше'); i:=i+1; end
  else
  if a>b then
  begin writeln('Больше'); i:=i+1; end;
  end;
  writeln('Попыток было:', i)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика