написать программу. составить блок схему. вставить заданное число в массив целых чисел перед последним четным элементом.

анарка3 анарка3    1   09.06.2019 11:40    3

Ответы
fumymovie fumymovie  08.07.2020 08:36
Const
    m = 10; 
var
    a: array[1..m+1] of integer;
    i, k: integer;
begin     
write ('Исходный массив: ');   
for i := 1 to m do
  begin
  a[i] := random(100);
  write (a[i],'; ');
  end;   
writeln; 
write('Введите число: ');
readln(k);
for i:=m+1 downto 1 do
  begin
  a[i]:=a[i-1];
  if a[i] mod 2=0 then
    begin
    a[i-1]:=k;
    break;
    end;
  end;
write('Измененный массив: ');  
for i := 1 to m+1 do
         write (a[i],'; ');  
end.
написать программу. составить блок схему. вставить заданное число в массив целых чисел перед последн
написать программу. составить блок схему. вставить заданное число в массив целых чисел перед последн
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика