Написать программу, которая в зависимости от введенного количества минут (m < = 60) будет подставлять слово минута в нужном падеже например, 25 минут 31 минута 53 минуты (используя оператор case и операции div и mod)

Fqx Fqx    1   19.05.2019 16:00    5

Ответы
AndreyPulik AndreyPulik  30.09.2020 23:33

var

  M:byte;

begin

  write('M = '); readln(M);

  case M div 10 of

    1: writeln(M, ' минут');

    else

      case M mod 10 of

        0, 5..9: writeln(M, ' минут');

        1: writeln(M, ' минута');

        2..4: writeln(M, ' минуты');

      end;

  end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика