Написать программу с++ заполнить массив двадцатью первыми натуральными числами,делящимися нацело на 13 или на 17 и находящимися в интервале,левая граница которого равна 300

katenabulasheva katenabulasheva    1   10.09.2019 01:40    0

Ответы
santilo1 santilo1  07.10.2020 04:32
C++14

#include <iostream>
#define k 20
using namespace std;
int main() {
int arr[k];
bool flag = false;
for(int i = 0, l = 1; i < k; ++i){
arr[i] = l*((!flag)?13:17);
if(flag) l++;
flag = !flag;
if(arr[i] >= 300)
cout << arr[i] << " ";
else
--i;
}
return 0;
}
Написать программу с++ заполнить массив двадцатью первыми натуральными числами,делящимися нацело на
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика