Написать программу с языка программирования паскаль по нахождению ответа на вопрос: войдет ли круг диаметром d в прямоугольную рамку размером а на b составить программу просто молю, скажите как решать, , желательно с подробным ! 9 класс

Сас111 Сас111    1   15.09.2019 08:00    4

Ответы
DarkLooord DarkLooord  07.10.2020 16:33
Сначала задача должна быть решена геометрически. Очевидно, что круг войдет в прямоугольник если его диаметр D будет меньше, чем меньшая из сторон этого прямоугольника min(a,b). Вот и все решение.

По этому решению составляем алгоритм:
1. Ввести a, b, D
2. Найти m - минимум (a,b)
3. Если D<m, то вывести сообщение "Войдет", иначе вывести сообщение "Не войдет".
4. Завершить работу.

Осталось написать программу.

1. Современное решение

// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,d):=ReadReal3('Введите через пробел a,b,D:');
  var m:=Min(a,b);
  if D<m then Writeln('Войдет')
  else Writeln('Не войдет')
end.

Пример
Введите через пробел a,b,D: 14.5 11 10.6
Войдет

2. "Школьный" вариант - так писали наши отцы и деды

var
  a,b,D,m:real;

begin
  Write('Введите через пробел a,b,D: ');
  Read(a,b,d);
  if a<b then m:=a
  else m:=b;
  if D<m then Writeln('Войдет')
  else Writeln('Не войдет')
end.
ПОКАЗАТЬ ОТВЕТЫ
dima0124124 dima0124124  07.10.2020 16:33
Var a,b,D:integer;
begin
readln(a,b);
readln(D);
if (D<=a) and (D<=b) then writeln('YES')
else writeln('NO');                          
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика