tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу решения
Написать программу решения следующей : определить периметры трѐх треугольников, если заданы координаты их вершин. использовать подпрограмму-функцию
maxzhusupov198p016yd
2 23.09.2019 20:00
5
Ответы
f0xses
01.05.2020 17:44
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 uses crt; var i,xa,ya,xb,yb,xc,yc: integer; function Dlina(x1,y1,x2,y2: integer):real; var d: real; begin d:= sqrt(sqr(y1-y2)+sqr(x1-x2)); Dlina:=d; end; function Perimetr(a,b,c: real): real; begin Perimetr:=a+b+c; end; procedure Vvod (nt: byte; var ax,ay,bx,by,cx,cy: integer); begin writeln ('Координаты вершины A ',nt,' треугольника'); readln (ax,ay); writeln ('Координаты вершины B ',nt,' треугольника'); readln (bx,by); writeln ('Координаты вершины C ',nt,' треугольника'); readln (cx,cy); end; begin for i:=1 to 3 do begin Vvod (i,xa,ya,xb,yb,xc,yc); writeln ('Периметр ',i,' треугольника = ',Perimetr(Dlina(xa,ya,xb,yb),Dlina(xb,yb,xc,yc),Dlina(xc,yc,xa,ya)):0:2); writeln; end; readkey end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
agharkova2014
22.04.2020 11:22
99!! = 1·3·...·97·99 составьте программу найти факториал...
pety1234
22.04.2020 11:22
Сост. прогр. Рез-ты экзаменов представлены в виде списка из N строк, в кажд. строке кот. записаны фам. студента и отметки по кажд. из M экзам. Найти кол-во студ., сдавших экзамены...
алана24
22.04.2020 11:22
Непрерывная задача о рюкзаке. Имеются n предметов. Для каждого предмета i (i=1, 2, ..., n) известен вес gi и прибыль ci, которая получается при транспортировке. Имеется рюкзак,...
AMG777555
08.02.2020 19:48
Напишите программу: программа генерирует случайное n (от -100 до 100). в цикле n раз генерируется другое случайное число x. подсчитать и вывести количество х кратных трём, отдельно...
Антоша007
08.02.2020 19:41
Решить: 4.10 4.11 4.12 (рисунки к ним тоже на фото )...
vikaplmplmpl
08.02.2020 19:32
Укажи и напиши источник информации ...
Zipchik
24.05.2020 17:25
7)Рассчитайте время представления фильма, занимающего объем памяти 660 Мбайт, на экранемонитора в разрешением 800*600 пикселей и палитрой из 256 цветов, если за 1ссменяется 24 кадра....
dfrt2
01.10.2019 15:32
Посчитайте количество танков в роте и общее количество танков в батальоне. желательно с решением...
Dashuta03s
01.10.2019 16:10
Написать программу,в которой формируется одномерный массив из 15 чисел,введенных с клавиатуры..вывести этот массив в столбик буду !...
11Катя11111
06.10.2019 23:50
Даны х,у,z. напишите программу для вычисления а=(1+z) x+у/x2+4/2+/1/x2+4 /-дробь...
Популярные вопросы
Когда меняться знаки больше или меньше?...
3
1.как восхвалялась в империи личность императора цин? 2.почему войны с китаем...
2
Скільки електронів має такіон натрію?...
2
1 you do the shopping. i did ityesterday.2 we buy tickets for the show.entrance...
1
7класс | ! всё на картинкедо 22.01.2020...
3
Жұптық жұмыс. мәтінге сүйеніп, әртіспен кездесудің жоспа- рын кесте түрінде жаз....
3
Задайте общий вопрос к предложению: they are working in our garden....
3
ответить на вопросы , 8 класс, шинель...
2
Из одного населённого пункта одновременно выехали в одном направлении легковая...
2
Сделать морфологический разбор прилагательных: глиняного кувшина,прекраснейшему...
2