Напишите программу:
программа генерирует случайное n (от -100 до 100). в цикле n раз генерируется другое случайное число x. подсчитать и вывести количество х кратных трём, отдельно - список х меньших 0, отдельно сумму х больших 50 подсказка: для каждого искомого значения нужна отдельная переменная

AMG777555 AMG777555    3   08.02.2020 19:48    4

Ответы
LollyMelor LollyMelor  23.08.2020 13:41

C# 8.0:

using System;

using System.Collections.Generic;

...

Random rnd = new Random();

long SumOfGreater50 = 0, Mult3 = 0, Num, n = 10;

var Negative = new List<long>();

for (; n > 0; n--)

{

   Num = rnd.Next(-100, 101);

   if (Num % 3 == 0)

       Mult3++;

   if (Num > 50)

       SumOfGreater50 += Num;

   if (Num < 0)

       Negative.Add(Num);

}

Console.WriteLine($"Num of multipliers of 3: {Mult3}");

Console.WriteLine("Negative nums:");

foreach (long i in Negative) Console.Write($"{i} ");

Console.WriteLine($"\nSum of nums greater than 50:{SumOfGreater50}");

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика