Написать программу проверки возрастного ограничения в кинотеатрах

ТупенькийОрешек243 ТупенькийОрешек243    1   20.08.2019 19:10    3

Ответы
nebeca nebeca  05.10.2020 07:53
//прога на Pascal
type
film = record
name : string[20];
age : byte;
end;
var
a: array of film;
n, i: byte;
begin
write ('Введите кол-во фильмов: ');
readln (n);
setLength (a, n);
for i:=0 to n-1 do
begin
write ('Введите название фильма ', i+1, ': ');
readln (a[i].name);
write ('Введите возрастное ограничение фильма ', i+1, ': ');
readln (a[i].age);
end;
writeln ('Введите возраст зрителя: ');
readln (n);
writeln ('');
for i:=0 to length (a)-1 do
begin
if n>a[i].age then write ('Этот зритель может ') else write ('Этот зритель не может ');
writeln ('пойти на фильм "', a[i].name, '"');
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика