Написать программу, которая получает на 10 элементов и записывает их в массив. Также программа получает на вход число. Необходимо посчитать сколько раз это число встречается в массиве.

Joker455 Joker455    2   28.01.2022 08:14    9

Ответы
diana5974767 diana5974767  28.01.2022 08:20

Відповідь:

#include <iostream>

using namespace std;

const int size = 10;

void cinarr(int *arr,const int size){

int counter = 1;

for(int i = 0; i < size; i++){

 cout << "Введите " << counter << " елемент массива: ";

 cin >> arr[i];

 counter++;

}

}

void printarr(int *arr, const int size){

for(int i = 0; i < size; i++){

 cout << arr[i] << " ";

}

}

int expression(int *arr,const int size,int number){

int counternumber = 0;

for(int i = 0; i < size; i++){

 if(number == arr[i]){

  counternumber++;

 }

}

return counternumber;

}

int main(){

setlocale(LC_ALL , "Rus");

int number;

cout << "Введите число которое будем искать: ";

cin >> number;

int *arr = new int [size];

cinarr(arr,size);

printarr(arr,size);

cout << "\nТаких чисел в массиве: " << expression(arr,size,number) << endl;;

delete [] arr;

return 0;

}

Пояснення:


Написать программу, которая получает на 10 элементов и записывает их в массив. Также программа получ
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика