Написать программу (процедуру), выводящую квадраты чисел от a до b (a,b вводятся с клавиатуры);

luiza151661 luiza151661    1   25.06.2019 05:30    2

Ответы
Whitewarrior98 Whitewarrior98  20.07.2020 14:20
И всё-таки, мне кажется, что надо вывести именно полные квадраты чисел в указанном диапазоне, иначе формулировка была бы типа: "Возведите в квадрат все числа в указанном диапазоне". Код на паскале:
var a, b, i, j : integer;
begin
readln(a, b);
for i := a to b do
begin
j := round(sqrt(i));
if j*j = i then writeln(i);
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика