Написать программу при операций div и mod. 1. задано двузначное число. найдите среднее арифметическое цифр числа.

Maybejuliar1337 Maybejuliar1337    1   06.10.2019 02:20    8

Ответы
bgi432 bgi432  05.08.2020 01:49

var  

 a: integer;

 b,c,s: real;

begin

 writeln('Введите число');

 read(a);

 b:=a div 10;

 c:=a mod 10;

 s:=(b+c)/2;

 writeln('Среднее арифметическое: ',s);

end.  

ПОКАЗАТЬ ОТВЕТЫ
Dahsa007 Dahsa007  05.08.2020 01:49

var a,b,c:integer;

   s:real;

begin

writeln('Введите двузначное число:');

read(a);

b:=a mod 10;

c:=a div 10;

s:=(b+c)/2;

writeln('Среднее арифметическое: ',s);

end.    

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика