Написать программу (полностью) для нахождения произведение суммы нечетных цифр и их минимума в четырехзначном числе. программа должна начинаться следующим образом и не содержать иных переменных кроме данных. var min, digit, s, n, res : integer; begin readln(n); входные данные: четырехзначное число. выходные данные: результат
... - уже данный код в условии
s := 0;
min := 10;
for res := 1 to 4 do
begin
digit := n mod 10;
if (digit mod 2 = 1) then
begin
s += digit;
if (digit < min) then
min := digit;
end;
n := n div 10;
end;
writeln(s * min);
end.