Для заданного одномерного массива с компонентами вещественного типа написать программу решения : вычислить разность между наибольшим и наименьшим элементом.

00LenaVaganova11 00LenaVaganova11    1   18.05.2019 06:10    4

Ответы
emmavalse emmavalse  11.06.2020 12:16

program fnued;

uses crt;

var a:=array [1..1000] of integer;

      i,n,max,min,r:real;

begin

clrscr;

readln(n);

for i:=1 to n do

readln(a[i]);

min:=a[1];

max:=a[1];

for i:=1 to n do

if a[i]>max then max:=a[i];

for i:=1 to n do

if a[i]<min then min:=a[i];

r:=max-min;

writeln(r);

readln;

end.

 

ПОКАЗАТЬ ОТВЕТЫ
ммрк ммрк  11.06.2020 12:16


program massiv;
var
a:array[1..10] of integer;
i,b,c : integer;
begin
writeln ('posledovatelno vedity elementi massiva (10 chisel)');
for i:=1 to 10 do
readln(a[i]);
b:=a[1];
for i:=1 to 10 do
begin
if a[i]>b then
b:=a[i];
end;
c:=a[1];
for i:=1 to 10 do
begin
if a[i]<c then
c:=a[i];
end;
writeln('raznost mesdu naibolshim i naimenshim elementom massiva =',b-c);
readln;
end.

p.s если нужны пояснения то в личку

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика