Написать программу по определению,попадает ли точка в синюю область .


Написать программу по определению,попадает ли точка в синюю область .
Написать программу по определению,попадает ли точка в синюю область .

basik2017 basik2017    3   20.10.2020 05:52    4

Ответы
лизалол лизалол  19.11.2020 05:52

1)

program z1;

var x,y: integer;

begin

write ('x = ');

readln (x);

write ('y = ');

readln (y);

if (y>0) and (x*x+y*y<4) then writeln('Точка попадает в синюю область')

else writeln('Точка не попадает в синюю область')

end.

2)

program z1;

var x,y: integer;

begin

write ('x = ');

readln (x);

write ('y = ');

readln (y);

if (x<0) and(y<0) and (x*x+y*y<5) then writeln('Точка попадает в синюю область')

else writeln('Точка не попадает в синюю область')

end.

Объяснение:

Проекции точки на оси x и y являются катетами прямоугольного треугольника. Гипотенуза - расстояние от начала координат до точки.

Чтобы точка принадлежала кругу расстояние до точки должно быть меньше радиуса.

Поскольку здесь половина и четверть круга, добавляем ограничения по х и у.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика