Написать программу по информатике в виде теста должны предлагаться вопросы с примерами , например 6*7=? нужно написать ответ и если правильно , то в конце выходит какой-то комментарий ( молодец! ) , а если наоборот , то например "не правильно. ответ: " и выводится правильный ответ . желательно , чтобы этот тест состоял из 5 примеров , а в конце оценивался например 5 правильных ответов , значит 5, 4 правильных-4 и так далее

blackfox30 blackfox30    1   21.08.2019 20:40    0

Ответы
ilslim ilslim  05.10.2020 10:02
Program test;
var ans,k,a,i,b: integer;
begin
randomize;
k:=0;
for i:=1 to 5 do
begin
a:=random(10)+1;
b:=random(10)+1;
writeln(i,' пример: ');
write(a,'*',b,'=');
readln(ans);
if ans=a*b then
begin
writeln('верно');
k:=k+1;
end
else
writeln('неверно, ответ: ',a*b);
end;
write('правильно ',k,' из 5, ваша оценка: ',k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика