Написать программу перевода из десятичной системы счисления в двоичную при функций пользователя. паскаль(функции пользователя).

kami654 kami654    1   21.08.2019 11:40    2

Ответы
bgf62 bgf62  05.10.2020 09:12
Program n1;
var n: integer;
function per(n: integer ): integer;
var
a: array[1..500] of integer;
i,c:integer;
begin
c:= 0;
repeat
c:= c + 1;
a[c]:= n mod 2;
n:= n div 2;
until n = 0;
for i:= c downto 1 do
write(a[i]);
end;
begin
write('введите число: ');
readln(n);
per(n);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика