Написать программу Pascal abc
В шкатулке хранится разноцветный бисер (или бусины). Все бусины имеют одинаковую форму, размер и вес. Бусины могут быть одного из N различных цветов. В шкатулке много бусин каждого цвета.
Требуется определить минимальное число бусин, которые можно не глядя вытащить из шкатулки так, чтобы среди них гарантированно были две бусины одного цвета.
Входные данные
Входной файл INPUT.TXT содержит одно натуральное число N - количество цветов бусин (1 ≤ N ≤ 109).
Выходные данные
В выходной файл OUTPUT.TXT выведите ответ на поставленную задачу.

Natanahgy Natanahgy    1   12.04.2020 17:26    20

Ответы
Maksat3232123 Maksat3232123  13.10.2020 03:01

var N: integer;

var f: text;  

begin

assign(f,'C:\1\INPUT.TXT');

reset(f);

read(f,N);

close(f);

assign(f,'C:\1\INPUT.TXT');

rewrite(f);

write(f,N+1);

close(f);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика