Написать программу, определяющую (отвечающею на вопрос) - больше ли числа х сумма цифр введённого числа

лев652 лев652    2   19.08.2019 22:20    3

Ответы
siylvio siylvio  24.04.2020 03:58
Var a,b,x,s:integer;
begin
write('a = ');
readln(a);
write('x = ');
readln(x);
b:=a;
s:=0;
while b>0 do
 begin
 s:=s+b mod 10;
 b:=b div 10;
 end;
writeln('s = ',s);
if s>x
 then writeln('Сумма цифр больше ',x)
 else writeln('Сумма цифр не больше ',x);
end.

Пример:
a = 31854
x = 15
s = 21
Сумма цифр больше 15
ПОКАЗАТЬ ОТВЕТЫ
Anastasia7wr Anastasia7wr  24.04.2020 03:58
#include <iostream>
#include <stdlib.h>
using namespace std;

int main() {
    int a,x,s=0;
    cin >> a >> x;
    for(;abs(a)>0;s+=abs(a)%10,a/=10);
    cout << (s > x ? "more" : "not more") << endl;   
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика