Написать программу напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3. программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется число, кратное 3. количество чисел не превышает 100. введённые числа не превышают 300. программа должна вывести одно число – сумму чисел, кратных 3.

alexsashinav alexsashinav    1   30.07.2019 09:50    4

Ответы
лизокумнок лизокумнок  07.08.2020 21:58
Var
n,a,i,s:integer;
begin
readln(n);
s:=0;
for i:=1 to n do
begin
readln(a);
if a mod 3=0 then
s:=s+a;
end;
writeln(s);
end.
ПОКАЗАТЬ ОТВЕТЫ
vikailen vikailen  07.08.2020 21:58
//Pascal ABC.NET 3.1

begin
 var n:=readinteger();
 var ar:=readArrInteger(n);
 writeln(ar.where(x -> x mod 3=0).sum);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика