Написать программу нахождения числа дней в месяце, если даны: номер месяца n – целое, также дано число а, равное 1 для високосного года и равное 0 в противном случае.
Var a:array[1..12]of integer; m, n:integer; Begin a[1]:=31;a[7]:=31; a[2]:=28;a[8]:=31; a[3]:=31;a[9]:=30; a[4]:=30;a[10]:=31; a[5]:=31;a[11]:=30; a[6]:=30;a[12]:=31; Write('Введите номер месяца -> '); Readln(m); Write('Год високосный(1 - да || 0 - нет)?'); Readln(n); if (m = 2) then Writeln(a[m] + n) else Writeln(a[m]); end.
a:array[1..12]of integer;
m, n:integer;
Begin
a[1]:=31;a[7]:=31;
a[2]:=28;a[8]:=31;
a[3]:=31;a[9]:=30;
a[4]:=30;a[10]:=31;
a[5]:=31;a[11]:=30;
a[6]:=30;a[12]:=31;
Write('Введите номер месяца -> ');
Readln(m);
Write('Год високосный(1 - да || 0 - нет)?');
Readln(n);
if (m = 2) then Writeln(a[m] + n) else
Writeln(a[m]);
end.