Написать программу на языке программирования паскаль. сведения о товарах включают: название, цену, количество и фирму-поставщика. описать данные в виде записи, создать файл из нескольких записей и напечатать, какие товары поставляет данная фирма.

Kharin86 Kharin86    3   26.09.2019 19:30    2

Ответы
r8n73x9999 r8n73x9999  08.10.2020 20:55
PascalABC.NET 3.4.0, сборка 1672 от 10.06.2018
Внимание! Если программа не работает, обновите версию!

type
  tТовар=record
    Название:string[32];
    Цена:real;
    Количество:real; // может быть в килограммах или тоннах
    Поставщик:string[32]
    end;

begin
  var b:tТовар;
  var f:file of tТовар;
  // создаем (или чистим), а затем заполняем файл
  Rewrite(f,'Товары.typ');
  loop ReadlnInteger('Количество товаров:') do begin
    Writeln('Введите информацию по очередному товару');
    b.Название:=ReadlnString('Название:');
    (b.Цена,b.Количество):=ReadlnReal2('Цена товара и его количество:');
    b.Поставщик:=ReadlnString('Поставщик:');
    Write(f,b)
    end;
  f.Close;
  // работаем с файлом
  Reset(f);
  var nf:=Trim(ReadlnString('Какой поставщик интересует?'));
  while not eof(f) do begin
    Read(f,b);
    if Trim(b.Поставщик)=nf then
      Println(b.Название,b.Цена,b.Количество)
    end;
  f.Close
end.

Написать программу на языке программирования паскаль. сведения о товарах включают: название, цену, к
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика