написать программу на языке паскаль нахождение корней квадратного уравнения при заданных a,b,c

ann111111113 ann111111113    1   19.05.2020 20:56    4

Ответы
Eliiiii099 Eliiiii099  15.10.2020 01:08

var a, b, c, x1, x2, e, d : real;

BEGIN

    WriteLn('Введите коэффициенты уравнения a,b,c:');

    ReadLn(a, b, c);

    d:= b*b - 4*a*c;

    e:= b/(2*a);

    if d<0 then WriteLn('Мнимые корни')

    else if d=0 then WriteLn('Корни квадратного уравнения: x1=x2', -e)

    else

        begin

             x1:= -e+sqrt(d)/(2*a);

             x2:= -e-sqrt(d)/(2*a);

             WriteLn('Корни квадратного уравнения: X1=', x1:6:2, ', X2=', x2:6:2);

        end

END.

ПОКАЗАТЬ ОТВЕТЫ
aydanxudieva14 aydanxudieva14  15.10.2020 01:08

главное не забыть про ; и точку в конце, а также не стоит забывать про значок *, который означает умножение и без него программа не заработает.


написать программу на языке паскаль нахождение корней квадратного уравнения при заданных a,b,c
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика