Написать программу на языке паскаль,которая считывает с клавиатуры строку s, состоящую из цифр. в заданном строкой s натуральном n-разрядном числе упорядочить цифры так, чтобы получить наибольшее число, записанное теми же цифрами. строка s не пустая и содержит не более 200 символов. строка s состоит только из цифр.

ranilgalimzyanov ranilgalimzyanov    2   05.06.2019 02:00    3

Ответы
diana2005n diana2005n  05.07.2020 18:29
S, a, d:string;
i,  n, j, b:integer;
c:array[1..200] of integer;
begin
readln(s);
readln(n);
a:=copy(s, 1, n);
for i:=1 to n do
val(a[i], c[i]);
for i:=1 to n do
for j:=1 to n do
if c[i]<c[j] then begin
b:=c[i]; c[i]:=c[j]; c[j]:=b; end;
for i:=1 to n do
str(c[i], d[i]);
s:=d;
writeln(s);
readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика