Написать программу на языке паскаль для нахождения площади треугольника по трем сторонам

алсу150 алсу150    1   17.07.2019 05:10    4

Ответы
99Dia 99Dia  21.09.2020 15:50
Площадь треугольника по 3м сторонам вычисляется по формуле Герона: \sqrt{p*(p-a)*(p-b)*(p-c)}, где p-полупериметр.
Тогда:

var a,b,c,p:real;
begin
  writeln('Введи длины сторон a, b и c');
  readln(a,b,c);
  p:=(a+b+c)/2;
  writeln('Площадь этого треугольника = ', sqrt(p*(p-a)*(p-b)*(p-c)));
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика