Написать программу на языке Pascal Задано произвольное число. Проверить является ли оно нечетным.

snowpanzer snowpanzer    3   08.06.2020 02:25    1

Ответы
ivanvlasuyk80 ivanvlasuyk80  08.06.2020 02:26

var a, b: byte;

begin

randomize;

a := random(100);

b := random(100);

if ((a mod 2 = 0) and (b mod 2 = 0)) or ((a mod 2 <> 0) and (b mod 2 <> 0)) then

a := a + 1;

writeln(a,' ',b);

if a mod 2 <> 0 then

writeln(a)

else

writeln(b);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика