tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу на с++
Написать программу на с++ надо вывести из строки со словами разделенными пробелами , вывести слова в которых буквы не повторяются
donchikbukhmas
2 03.09.2019 00:50
4
Ответы
Nisson1
06.10.2020 13:35
#include<iostream>
#include<string>
using namespace std;
int main()
{
string S;
cout << "BBEDITE TEXT: ", getline(cin,S);
S+=' ';
string Slovo = "";
for (int i = 0; i < S.length(); i++)
{
if (S[i] != ' ') Slovo+=S[i];
else
{
bool B = 1;
for(int j = 0; j+1 < Slovo.length(); j++)
{
for(int m = j+1; m < Slovo.length(); m++)
{
if (Slovo[j] == Slovo[m]) B = 0;
}
}
if (B) cout<<"\n" <<Slovo;
while (S[i] == ' ') i++;
Slovo=S[i];
}
}
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
RedomR
31.05.2019 11:30
Склавиатуры вводятся два числа. составить программу сравнивающую эти числа и в зависимости от результата сравнения выводящую на экран нужный знак.например: 3 5 или 3=3 или 3 2....
aksinaa9
01.12.2020 08:47
Сообщение записано при символьного алфавита и содержит 500 символов. Сколько информации несет данное сообщение (в битах)?...
yegor655
01.12.2020 08:59
Практическое занятие на тему : Построение логических схем нужна, очень, очень Тема 10-11 класс...
t11o
08.02.2021 16:16
Что такое вещественное число? Определи арифметические функции, результат выполнения которых будет вещественным числом. Верных ответов 2. Варианты: 1) abs(-25) 2) 5*2 3) 625/25 4)...
bWn
08.02.2021 16:16
Дан список из чисел 12, 34, 8, 15, 9, 26. Выведите на экран числа: а) меньше числа n; б) первое число больше n; в) сумму всех чисел больше числа n....
MrVyacheslav228
08.02.2021 16:15
Мне нужно создать игру по языку с++ программирования...
414484
08.02.2021 16:14
Задание 3 Между населенными пунктами A, B, C, D, E построены дороги, протяженность которых(в косметра приведена в таблице.A B C D EПостройте граф по данной таблице...
лабтвб
08.02.2021 16:14
Применение. Анализ 8. Запишите на языке Python арифметические выражения.а) 6,38.a,+a,+а, ,b)3c) 2 + ax: 3.d) 15 + |13 – 36].е) -24,8 х 10.f) a + 8bx + 15cyz.ab Cg)Cabb) x+y, a,а.х...
amwarawka
08.02.2021 16:04
Составьте программу формирования массива A (N) из двух массивов B (M) и C (K ), таким образом, чтобы элементы массива A (N) распологались по возрастанию....
Empresssss
08.02.2021 16:04
Задание 12**. Вычисли целую часть, остаток выражения 1)28//5= 2)15//25= 3)65//4= 4)22//22= 5)100/20= 1)26% 26= 2)15% 14= 3)36% 14= 4)22% 3= 5)89% 20= 1)(12% 10)//14= 2)(15//14)%=...
Популярные вопросы
Как изменяются неметаллические признаки элементов в ряду f - cl - br - i?...
1
Найдите производящие слова для следующих существителтных: пуск- белизна- смелость-...
2
Мое любимое стихотворение лермонтова...
3
Кусок ткани длиной 76 м разрезали на три части. первая из них имеет длину 25...
1
На асфальте нарисована дорожка в форме равнобедреного треугольника. вася хочет...
1
Сочинение на тему можно ли обойтись без книг...
2
Какое перемещение совершит тело за 10 мин, если уравнение движения тела имеет...
2
Подскажите короткий рассказ про доброе волшебное слово 3 класс...
3
Cоставьте формулы веществ по названиям: а) бромид кальция б) оксид марганца (iv)...
2
Каким фонетическим признаком объединены следующие слова: подсечь, вязкий, ложка,...
2
#include<string>
using namespace std;
int main()
{
string S;
cout << "BBEDITE TEXT: ", getline(cin,S);
S+=' ';
string Slovo = "";
for (int i = 0; i < S.length(); i++)
{
if (S[i] != ' ') Slovo+=S[i];
else
{
bool B = 1;
for(int j = 0; j+1 < Slovo.length(); j++)
{
for(int m = j+1; m < Slovo.length(); m++)
{
if (Slovo[j] == Slovo[m]) B = 0;
}
}
if (B) cout<<"\n" <<Slovo;
while (S[i] == ' ') i++;
Slovo=S[i];
}
}
return 0;
}