написать программу на python Создай базу интересов. Сначала у первого пользователя запрашиваем число интересов, которое он хочет ввести, затем он вводит их и они добавляются в первое множество. Ту же самую операцию проводим для второго пользователя.
Результат работы программы. Программа выводит на экран множество, в котором записаны совпавшие интересы. Если совпадений нет, программа выводит строку ‘Нет общих интересов’.


написать программу на python Создай базу интересов. Сначала у первого пользователя запрашиваем число

Maara Maara    3   28.01.2021 14:55    11

Ответы
Alinasia Alinasia  28.01.2021 15:00

interests1 = [input(f"Введите {i+1} интерес: ") for i in range(int(input("Введите кол-во интересов: ")))]

interests2 = [input(f"Введите {i+1} интерес: ") for i in range(int(input("2Введите кол-во интересов: ")))]

general = []

for i in interests1:

   for ii in interests2:

       if i == ii:

           general.append(i)

if len(general) != 0:

   print(f" {len(general)} общих интереса:  {general}")

else:

   print("Нет общих интересов")


написать программу на python Создай базу интересов. Сначала у первого пользователя запрашиваем число
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика