Написать программу на паскале вывести квадраты и кубы 10 чисел следущей последовательности: 1, 2, 4, 7, 11, 16..

kate832 kate832    3   07.07.2019 23:10    1

Ответы
olaseve2007ls olaseve2007ls  31.07.2020 01:27
Данная последовательность -- последовательность центральных многоугольных чисел. Вычисляется по формуле a(n) = n*(n+1)/2 + 1. Или a(1) = 1, a(n+1) = a(n) + n.

Var
  a, i: integer;
Begin
  a := 1;
  for i := 1 to 10 do
  begin
    writeln('base=', a, 'square=', a*a, ' cube=', a*a*a);
    inc(a, i);
  end

End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика