tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу на паскале
Написать программу на паскале для вычисления стоимости покупки, состоящей из нескольких тетрадей и такого же количества обложек к ним. результат должен выводиться в денежном формате, например, 145руб. 30коп.
lHoneyl
2 23.09.2019 09:30
2
Ответы
Гули0203
08.10.2020 12:00
Program n_5;
var
a, b: real;
c: integer;
begin
write('Введите стоимость тетради - '); readln (a);
write('Введите стоимость обложки - '); readln (b);
write('Введите кол-во тетрадей - '); readln (c);
if (a <= 0) or (b <= 0) or (c <= 0) then exit;
writeln;
write('ИТОГО: ', trunc(c * (a + b)), ' руб. ', round(((c * (a + b)) - (trunc(c * (a + b*100), ' коп.');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
ПоЗиТиВ4ЧиК
06.09.2019 23:00
17. зашифруйте фразу я учу информатику с ключа шифр...
Olrg3007
06.09.2019 23:00
Написать данные даты в двоичной системе исчисления. 23.09.2002 01.09.2008 01.09.2017...
анонім2281104
07.07.2019 22:40
1. якою буде формула =a2*b2 з клітинки с2 після її копіювання в с3? =a2*b2 =a3*b3 =b2*c2 =b3*c3 2. якою буде формула =a2*$b$2 з клітинки с2 після її копіювання в с3? =a2*$b$2 =a3*$b$2...
Tolganay11
07.07.2019 22:40
До комірки вз увели формулу =(d2+$f$2)*$g$2. потім цю формулу поширили вниз. в комірці в6 записана формула: =(d6+$f$2)*$g$2; =(d5+$f$2)*$g$2; =(b6+$f$6)*$g$2; =(d5+$f$2)*$g$6....
nik180208
07.07.2019 22:40
Задан одномерный массив а[1..15]. определить сумму четных положительных элементов массива с n-го по k-й....
alenaafaunova
08.07.2019 12:40
Дан массив из 5 элементов, составить программу, которая возводит в квадрат элементы, которые как кратные 4, так и положительны...
snejanas1
28.05.2019 03:50
Выделяются 5 поколений вычислительный техники по использованию элементной базы на основе которой они работали. укажите какая строчка соответствует эвм 2 поколения. а) элементы на...
thero10
28.05.2019 03:50
Как сделать работу по информатике стр 47 н2 2класс...
vikakittenlove
09.06.2019 07:30
Какие система описания цвета существует?...
Luhfeeqq
09.06.2019 07:30
Можно ли из документа сделать шаблон?...
Популярные вопросы
Упражнение 3. Поставьте предложенные в скобках прилагательные в соответствующую...
2
Очень слаб по математике, кто слегка понимает ....
1
На цилиндр радиусом R = 0,046 м, который может вращаться вокруг горизонтальной...
3
Наватарски падыход да увасаблення минулага у Князь Витаут Дударева...
1
Определите признаки, характерные для муссонов: 1. Летом дует с поверхности океана...
1
Ha python. Написать программу, позволяющую по последней цифре числа определить...
3
ответьте на тест Для какой группы растения их жизненным форма характерны следующие...
3
Напишите код на С за правильый ответ Омкар получил сообщение от Антона: «Ваша...
3
Скорость тела изменяется по закону: v = Ct2, где C = 0,9 м/с3. Какой путь (в метрах)...
1
Диагонали параллелограмма РМЕК пересекаются в точке О. Для каждой пары векторов...
2
var
a, b: real;
c: integer;
begin
write('Введите стоимость тетради - '); readln (a);
write('Введите стоимость обложки - '); readln (b);
write('Введите кол-во тетрадей - '); readln (c);
if (a <= 0) or (b <= 0) or (c <= 0) then exit;
writeln;
write('ИТОГО: ', trunc(c * (a + b)), ' руб. ', round(((c * (a + b)) - (trunc(c * (a + b*100), ' коп.');
end.