Написать программу на паскале абс дано трехзначное число. найдите его палиндром и произведение палиндрома и данного числа. числовой палиндром — это натуральное число, которое читается слева направо и справа налево одинаково. иначе говоря, отличается симметрией записи (расположения цифр), причём число знаков может быть как чётным, так и нечётным. например, 165 его палиндром 561.

Rin1111 Rin1111    3   15.07.2019 07:20    2

Ответы
ApuCTokpaT1 ApuCTokpaT1  30.08.2020 18:15
Program palidron;

var
   a, b, c, x, d: integer;

begin
      writeln('Число:');
       readln(a);
       b:= a mod 10;
       c:= (( a div 10) mod 10);
       x:= (( a div 10) div 10);
       d:= 100*b+10*c+x;
       writeln('Палиндром: ',b,c,x);
       writeln('Произведение числа и палиндрома: ',d*a);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика