Написать программу на паскаль дано натуральное число. вычислить количество цифр, являющихся степенями тройки (1,3,9).

SMokKK SMokKK    1   15.06.2019 06:30    3

Ответы
GALAXY356 GALAXY356  12.07.2020 13:52
Var n, digit, ans : integer;
begin
    read(n);
    ans := 0;
    while (n > 0) do begin
        digit := n mod 10;
        if ((digit = 1) or (digit = 3) or (digit = 9)) then
            ans := ans + 1;
        n := n div 10;
    end;
    writeln(ans);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика