Написать программу на найти наибольшую цифру числа и ее порядковый номер и найти сумму наибольшей и наименьшей цифры.

angelinadvuradkina angelinadvuradkina    2   25.08.2019 22:30    3

Ответы
толя151 толя151  05.10.2020 19:44
// PascalABC.NET 3.2, сборка 1399 от 08.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('n=');
  var p:=s.ToCharArray.IndexMax;
  Writeln('Максимальная цифра ',s[p+1],' имеет номер ',p+1);
  Writeln('Сумма наибольшей и наименьшей цифр равна ',
    s.Min.ToDigit+s.Max.ToDigit)
end.

Пример
n= 145384
Максимальная цифра 8 имеет номер 5
Сумма наибольшей и наименьшей цифр равна 9
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика