Написать программу на free pascal которая переводит число из десятичной системы в двоичную

Flif Flif    1   15.06.2019 00:20    2

Ответы
sinocek1 sinocek1  12.07.2020 11:28
Function ToBinaryString(x: integer): string;
var r, s: string;
begin
  if x < 0 then begin
    s := '-';
    x := -x;
  end;
  while x <> 0 do begin
    r := Chr((x and 1) or 48) + r;
    x := x shr 1;
  end;

  ToBinaryString := s + r;
end;

var x: integer;
begin
  readln(x);
  writeln(ToBinaryString(x));
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика