Написать программу на c++, которая переводит число из двоичной системы счисления в десятичную

valentinateleg2607 valentinateleg2607    2   27.05.2019 02:50    3

Ответы
Innka898989 Innka898989  01.10.2020 12:27

#include <iostream>

#include <string>

#include <cmath>

using namespace std;

void main(void){

setlocale(LC_ALL, "rus");

int i,sum=0,n,r=0;

char date[255];

cout << "Введите двоичное число"<< endl;

cin >> date;

n = strlen(date);

int *arr = new int[n];


for (i = 0; i < n; i++){

 arr[i] = (int)date[i] - (int)'0';

}

for (i = 0; i < n; i++){

 cout << arr[i] << " ";

}

cout << " " << endl;

for (i = 0; i < n; i++){

 r = r + arr[i]*pow(2, n - i-1);

}

cout << "Десятичное число равно" << r;


}


Написать программу на c++, которая переводит число из двоичной системы счисления в десятичную
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика