Написать программу, которая заполняет массив из 6 элементов случайными неповторяющимися целочисленными значениями от 1 до 49. после этого программа просит пользователя ввести 6 целых чисел от 1 до 49 (при вводе проверяется, что вводимое число соответствует данному условию; в противном случае число вводится повторно). программа считает, сколько чисел из введённых пользователем оказалась в массиве, и выводит их количество на экран. паскаль абс без плагеата program loto; uses crt; const lt = 49; (* количество шаров в лототроне *) shar = 6; (* количество выигрышных шаров*) var lott : array [1..lt] of integer; i, nom : integer; begin randomize; for i: =1 to lt do lott[i]: =i; i: =1; while i < = shar do begin nom : = random(49)+1; if lott[nom] < > 0 then begin write(lott[nom], ‘ ’); lott[nom] : = 0; i : = i+1; end; end; writeln; end. это начало по этой программе сделать

lotop lotop    2   24.08.2019 22:30    5

Ответы
nushales nushales  05.10.2020 17:30
Program Loto;
Uses Crt;
Const lt = 49; (* количество шаров в лототроне *)
shar = 6; (* количество выигрышных шаров*)
Var lott,vyb : array [1..shar] of integer;
i, j, nom, k : integer;
m:set of byte;
Begin
randomize;
m:=[];
for i:=1 to shar do
begin
repeat
nom:=1+random(lt);
until not(nom in m);
lott[i]:=nom;
m:=m+[nom];
end;
writeln('Выберите шаров от 1 до 6 ',lt);
m:=[];
begin
repeat
write('nom',i,'=');
readln(nom);
until (nom in [1..lt])and not(nom in m);
vyb[i]:=nom;
m:=m+[nom];
end;
clrscr;
writeln('Номера шаров в лототроне');
for i:=1 to shar do write(lott[i]:3);
writeln;
writeln('Выбранные шары');
for i:=1 to shar do
write(vyb[i]:3);
writeln;
write('Совпавшие шары: ');
k:=0;
for i:=1 to shar do
for j:=1 to shar do
if lott[i]=vyb[j] then
begin
k:=k+1;
write(lott[i]:3);
end;
if k=0 then write('- нет')
else write('  Их количество=',k)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика