Написать программу которая задает с клавиатуры рост 10 спортсменов из диапазона от 150 до 200см считает количество спортсменов рост которых больше 190см а также средний рост всех спортсменов

Era2008 Era2008    2   14.08.2019 00:10    2

Ответы
СашаСтоляров1 СашаСтоляров1  04.10.2020 17:19
Var
  a: array [1..10] of integer;
  i, s, k: integer;
 
begin

for i:=1 to 10 do
  begin
    Writeln('Рост спортсмена №',i,': ');
    Readln(a[i]);
    if a[i] > 190 then
      k:=k+1;
    s:=s+a[i];
  end;

Writeln(k, ' спортсмена(-ов) рост, которых составляет более 190 см.');

Writeln('Средний рост всех спортсменов составляет ', s/10,' см.');
 
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика