Написать программу, которая выводит на экран линейный массив из 10 случайных чисел. причем отрицательные элементы синим цветом, а положительные элементы – красным. pascal abc

умник202323 умник202323    1   26.09.2019 21:40    4

Ответы
Sravkur Sravkur  08.10.2020 21:10
Uses crt;
var
  a: array [1..10] of integer;
  i: byte;
 
begin
randomize;
writeln(' *** Исходный массив ***');
for i := 1 to 10 do
begin
  a[i] := random(50)-25;
  if a[i] < 0 then TextColor(1);
  if a[i] = 0 then TextColor(15);
  if a[i] > 0 then TextColor(4);
  write(a[i], ' ');
end;
TextColor(15);
writeln;  
end.
ПОКАЗАТЬ ОТВЕТЫ
ggdfjfxxglvx ggdfjfxxglvx  08.10.2020 21:10
Uses Crt;

var
  a:array[1..10] of shortint;
  i:byte;
begin
  randomize;
  for i:=1 to 10 do
  begin
    a[i]:=Random(21)-10;
    if a[i]<0 then TextColor(LightBlue)
    else if a[i]>0 then TextColor(LightRed)
    else TextColor(White);
    Write(a[i],' ')
  end;
  TextColor(White);
  Writeln
end.

Написать программу, которая выводит на экран линейный массив из 10 случайных чисел. причем отрицател
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика