Написать программу, которая выводит круговую диаграмму, отражающую товарооборот (в процентах) книжного магазина. Исходные данные (объем продаж в рублях по категориям: книги, журналы, открытки и канцтовары) вводятся во время работы программы. Пример диаграмму приведен ниже.


Написать программу, которая выводит круговую диаграмму, отражающую товарооборот (в процентах) книжн

КаРаТиСтКиОкУшИнА КаРаТиСтКиОкУшИнА    1   09.06.2020 21:57    9

Ответы
артем1151 артем1151  15.10.2020 13:33

Объяснение:

clrscr;

s:=0;

writeln('Vvedite tovarooborot po vidam:');

for i:=1 to 4 do

 begin

  write(x[i],'=');

  readln(y[i]);

  s:=s+y[i];

 end;

for i:=1 to 4 do

y[i]:=y[i]*100/s;

dr:=detect;

initgraph(dr,mode,'');

xc:=GetMaxX div 2;

yc:=GetMaxY div 2;

outtextxy(Xc-80,20,'Tovarooborot po vidam, %');

b:=round(360*y[1]/100);

r:=150;

setcolor(10);

setfillstyle(1,11);

pieslice(xc,yc,0,b,r);

for i:=2 to 3 do

 begin

  a:=round(360*y[i]/100)+b;

  setcolor(10+i);

  setfillstyle(1,10+i);

  pieslice(xc,yc,a,b,r);

  b:=a;

 end;

setcolor(14);

setfillstyle(1,14);

pieslice(xc,yc,b,360,r);

for i:=1 to 4 do

 begin

  setcolor(i+10);

  setfillstyle(1,i+10);

  bar(xc+150,i*40,xc+180,i*40+20);

  setcolor(15);

  str(y[i]:0:2,st);

  outtextXY(xc+190,i*40+5,x[i]+'-'+s

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика