Написать программу, которая вычисляет среднее арифметическое вводимой с клавиатуры последовательности дробных чисел. количество чисел должно задаваться во время работы программы. (цикл для)(паскаль )

annajortsorensen annajortsorensen    3   05.06.2019 19:20    8

Ответы
бэйба123 бэйба123  06.07.2020 07:44
Program Nooobodyyy;
uses crt;
var
  i,how:integer;
  ch,appr,sum:real;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln(); writeln();
  writeln('Программа запрашивает N дробных чисел и находит их среднее арифметическое');
  sum:=0;
  write('Введите количество чисел: '); readln(how);
  for i:=1 to how do
    begin
      write('Введите ',i,'-e число: '); read(ch);
      sum:=sum+ch;
    end;
  appr:=sum/how;
  writeln('Cреднее арифметическое равно ',appr:8:2);
end.
ПОКАЗАТЬ ОТВЕТЫ
covo1 covo1  06.07.2020 07:44
Var
  i, count : integer;
  summ, temp : real;
begin
  summ := 0;
  readln(count);
  for i := 1 to count do
  begin
    readln(temp);
    summ := summ + temp;
  end; 
  writeln(summ / count);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика