Написать программу, которая вводит массив и заменяет в нем все элементы, которые превышают 7, этим числом. вывести массив и кол-во замен.(в pascal)

Айнель2006 Айнель2006    1   17.03.2019 18:50    3

Ответы
ТиматиТорнадо ТиматиТорнадо  25.05.2020 21:17

const  

n=10;

var  

a : array [1..n] of integer;

i,k,m : integer;

begin

randomize;

k:=0;

writeln('введите число, на которое заменять элементы: ');

read(m);

writeln('Массив:');

for i:=1 to n do  

 begin

   a[i]:=random(10)+1;

   write(a[i]:4);

 end;

writeln;

for i:=1 to n do  

 if (a[i]>7) then  

   a[i]:=m;

writeln('изменённый массив:');

for i:=1 to n do  

 write(a[i]:4);

end.  

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика